Moto X Pure Edition (2015) + Sprint = no roam?

I have the Motorola Moto X Pure Edition (2105). It’s a great value, it’s unlocked, and it works on all major cell networks.

The phone worked great until this weekend. I went to Dinosaur Valley State Park near Glen Rose, TX for a campout with my Cub Scout pack. (I am Cubmaster.)

Glen Rose is in the middle of a large Sprint coverage gap, but at least there’s voice roaming:
Sprint in Glen Rose, TX
(from Sprint’s Coverage Check page)

And here’s the data coverage, which is “off-network roaming”:
Sprint data in Glen Rose, TX(from Sprint’s Coverage Check page)

The data roaming is only in theory. When I crossed into the roaming zone (westbound US 67 east of Glen Rose), I only had voice, no data.

Later that night, perplexed at the lack of data, I reviewed my phone’s roam settings. In the settings, I hit More under Wireless & networks, then Cellular networks. Here’s the dialog (notice the empty signal indicator to the left of the battery indicator):
Moto X cellular network settings

Below is what you see when tapping on System select:
Moto X system select

I changed this from the default Automatic to Home only. Predictably, the roam network disappeared. Changing back to Automatic, the roam network was still gone! Power cycling the phone had no effect.


The Preferred network type dialog had no effect. Here’s its default setting:
Moto X preferred network type

None of the other settings had any effect. I also tried toggling the Data roaming slider, but it had no effect. That makes sense because the phone detected no network anyway.

Somehow I got this alternate settings screen. I do not remember how I got that. Regardless, it had no effect. Here it is:
Moto X available networks

Sometimes I got a version of this that had two Extended Network selections:
Moto X available networks (two Extended Network selections)

Clicking on any Extended Network selection on either version of this settings screen had the same effect. You first see this for a while:
Moto X registering on extended network

Then you see this:
Moto X cannot connect

I also explored the Search networks and Choose automatically settings, but neither had any effect. The presence of Extended Network at the bottom makes it look like the phone in fact saw a network.

Ultimately, I got no cell access for the weekend. When we went home, I got an avalanche of text messages between Glen Rose and Cleburne. (They were alerts from an unprecedented IT outage at my employer.)

Did I need to update my phone’s preferred roaming list (PRL). I think no. First, if my PRL was bad, I wouldn’t have gotten any roaming as I traveled to Glen Rose. With the current PRL, I should have at least had voice the entire weekend. Second, I activated this phone just 13 days prior to the trip. Since the phone is unlocked and carrier agnostic, it would have to update its PRL upon activation. Even if an old PRL was buried in the phone, the lack of Sprint access at Glen Rose is not new, so a very old PRL ought to work fine.

What do I do? Is the Moto X unable to reliably roam if Sprint is my network? Have Motorola or Sprint acknowledged a bug?